On March 1, 2021, Neon CRM is ending support for TLS 1.0 and 1.1 in the Neon CRM API to ensure that we are providing our customers and partners with safe and secure protocols. This change is enforced throughout the industry to maintain secure connections that encrypt and protect your sensitive data from malicious breaches. This change is specific only to API connections, including both API v1 and API v2. Neon CRM previously disabled support for TLS 1.0 and 1.1 for most users connecting to the application over a web browser.

Am I affected?

Probably not. This change only affects API connections that relied on TLS 1.0 or 1.1. If you’re a software developer or you hired software developers to build an API-based integration with Neon CRM, read on.

For software developers: If you have created or currently maintain a software integration with Neon CRM using one of its APIs, you will need to ensure the client you use to connect to Neon CRM’s API supports at least TLS 1.2. You can use the tools on this website to test your API client’s compatibility with TLS 1.2.