Create Custom Object: isActive=TRUE

Home Forums General Issues Create Custom Object: isActive=TRUE

This topic contains 3 replies, has 2 voices, and was last updated by  Colin Pizarek 1 year, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2372

    Brian Hemesath
    Participant

    I’m setting the parameter “customObject.isActive” to TRUE during a createCustomObject call, but the custom object is not active after it is created. Can someone look at this? It adds a step for the user during our integration.

    https://api.neoncrm.com/neonws/services/api/customObject/createCustomObject?&userSessionId=ABC&customObject.objectLabel=Volunteer%20Hours%20Tracking&customObject.objectRecordName=RecordId&customObject.objectRecordDisplayFormat={0}&customObject.objectRecordDataType=AUTO_NUMBER&customObject.ObjectRecordStartNumber=1&customObject.isActive=TRUE

    {
        "createCustomObjectResponse": {
            "operationResult": "SUCCESS",
            "responseDateTime": "2017-09-22T17:09:27.004+0000",
            "customObject": {
                "objectId": 44,
                "objectName": "Volunteer_Hours_Tracking",
                "objectLabel": "Volunteer Hours Tracking",
                "objectApiName": "Volunteer_Hours_Tracking_c",
                "objectRecordName": "RecordId",
                "objectRecordStartNumber": 1,
                "objectRecordDisplayFormat": "{0}",
                "allowActivity": false,
                "allowReport": false,
                "objectRecordDataType": "AUTO_NUMBER"
            }
        }
    }
    #2389

    Colin Pizarek
    Keymaster

    It seems that activating upon creation, as you describe, is not working properly. I’ll report this to our developers. It’s possible they did not intend for that parameter to be present in that request. I say this because the UI requires some data to be present before activation. I think, though, it’s just a bug.

    That said, you can immediately update the custom object with a second API call to activate it. This part does seem to be working.

    https://api.neoncrm.com/neonws/services/api/customObject/updateCustomObject?userSessionId=abc123&customObject.objectId=44&customObject.isActive=TRUE

    • This reply was modified 1 year, 2 months ago by  Colin Pizarek.
    • This reply was modified 1 year, 2 months ago by  Colin Pizarek.
    #2403

    Brian Hemesath
    Participant

    Ok, the call to update the custom object works.

    If you could, update this thread if there is in fact a bug. That way I’m not making an extra API call in the future.

    Thank you.

    #2410

    Colin Pizarek
    Keymaster

    It is not a bug. We will be removing the isActive parameter from the Create Custom Object API method documentation.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.